privacy-policy-2117996_1920

WordPress 4.7.5 Security and Maintenance Release

This post contains affiliate links. For more information, see my disclosure policy

WordPress 4.7.5 Update Out Keep Your Site Secure!

WordPress 4.7.5 is now available. This is a security release for all previous versions and we strongly encourage you to update your sites immediately.

Six Security Issues covered in this release. These include XML-RPC API updates and XSS cross scripting vulnerabilities. Update today to keep your site secure.

Leave a Comment